Mail inviate dai terminali notes traveler sparite nel nulla (apparentemente)
Oggi voglio descrivervi un problema [risolto!] tanto fastidioso quanto insolito su cui ho dovuto lavorare non poco.
Tutte le mail inviate dagli utenti  tramite terminali traveler (Android o Ios indifferentemente) risultavano spedite correttamente, fin anche rintracciabili nei sent, ma non arrivavano ai destinatari.
Su server nessun errore veniva segnalato e nel log di Domino, nelle mail.box e nel journal delle mail non si trovava alcuna traccia. Sembravano scomparse nel nulla.
Tra l'altro del fenomeno non ci si è accorti subito, ma solo dopo qualche giorno che si è manifestato.

Dopo svariati tentativi e ricerche inutili, compreso aver eseguito traveler in modalità debug per capire se fosse presente un qualche errore che non veniva loggato di default, giusto prima di decidere se rifare tutto il server o aprire una chiamata con il supporto IBM, ho trovato la seguente segnalazione:
http://www-01.ibm.com/support/docview.wss?uid=swg21324865

Ho quindi impostato il parametro Mail_Enable_Mailbox_Compatibility=1 e ritrovato tutte le mail disperse.

Tale parametro server a forzare l'uso del file mail.box nel caso il server Domino sia stato configurato per utilizzare mail.box multiple per gestire le code d'invio. Quando infatti si utilizzano mailbox multiple il server crea n mailx.box, tante quante ne sono state configurate, ma lascia il file mail.box precedentemente creato.
Tale mail.box non viene più gestita dal task router e anche provandola ad aprire da client di amministrazione si viene rediretti ad una delle nuove mailx.box create.
Traveler però, in questo caso (ho tanti servers dove ciò non avviene), scriveva tutte le mail inviate dai terminali solo nella mail.box, non più gestita o consultabile, e ciò ha fatto pensare che "scomparissero nel nulla".

Quindi, appurato quanto sopra, ho deciso (per scrupolo ma anche per evitare di reinviare mail) di fermare il servizio domino, spostare da OS tutte le mail.box esistenti in un folder separato (ma sempre sotto la data) e far ripartire il servizio.
Alla ripartenza di Domino, in automatico, sono state ricreate tutte le mail.box e l'invio delle mail da terminali traveler ha ripreso a funzionare correttamente.

Fortunatamente l'anomalia si è presentata su un server interno Digiway, migrato di recente a piattaforma 64 bit dalla precedente 32 bit durante l'ultimo scampolo di vacanze estive. Sfortunatamente non ci si è accorti subito del problema sia per il periodo ma anche per il fatto che chi ha fatto tutte le prove di funzionamento (invio compreso) era attestato su un altro server traveler e altri invece avevano unicamente provato a leggere mail o aggiungersi appuntamenti (ma senza invitare terzi).

11/9/2013
Dario Marradi

Tags :  IBM Domino  IBM Notes Traveler  e-mail 

|
Commenti : (0)

nessun Commento trovato
Autore
Dario Marradi

Dario Marradi